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1 Introduction

BlomURBEX is a collection of Web Services provided by Blom that allow to
navigate through high-detailed maps with ortho and oblique imagery, and to fly
through 3D immersive cities. In addition, the Web Services can be invoked to
obtain measurement information about buildings and other map elements.

Blom leverages in Europe and around the world the production of a huge image
and 3D model database of more than 900 cities, and the database increases each
month as new countries are included in it. BlomURBEX offers the most detailed
and comprehensive imagery database and 3D models of urban places in the
market.

Based on the same interface, Blom is developing a full range of Plug-ins that
integrates BIomURBEX services in common GIS and CAD applications. Blom
development roadmap with BlomURBEX includes the following targets:

BlomURBEX Plug-in for ESRI ArcMap (ArcView, ArcEditor and ArcInfo)
BlomURBEX Plug-in for ESRI ArcIMS

BlomURBEX Plug-in for ESRI ArcGIS Server

BlomURBEX Plug-in for Intergraph GeoMedia Professional
BlomURBEX Plug-in for Integraph GeoMedia WebMap

BlomURBEX Plug-in for Autodesk Map and AutoCAD

BlomURBEX Plug-in for Autodesk MapGuide

BlomURBEX Plug-in for Bentley MicroStation

BlomURBEX Plug-in for MapInfo Professional

BlomURBEX Plug-in for MapInfo MapXtreme

Contact Blom at http://www.blomasa.com/contact.html for new releases and
updates.

1
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2 Version changes

Version 3.0.0 of BlomURBEX Plug-in for AutoCAD 2007/2008/2009
includes these improvements:

Added support for adding Blom Library as a data source.
“Display measurement tool results” option has been removed from

“Printing” options in “Settings”.

Better navigational controls for map.
Proxy settings will now get detected automatically.

Version 2.5.2 of BlomURBEX Plug-in for AutoCAD 2007/2008/2009
includes these improvements:

Fixed an error that causes a crash in AutoCAD when viewing obliques.
0OSGB36 projection supported.

Fixed a problem for viewing overlays in one view of multi-view layouts.
Fixed a problem refreshing overlays in obliques.

NTLM and Kerberos proxy authentication support.

Version 2.5.1 of BlomURBEX Plug-in for AutoCAD 2007/2008/2009
includes these improvements:

Better support for big geometries in overlays.

Version 2.5 of BlomURBEX Plug-in for AutoCAD 2007/2008/2009
includes these improvements:

All the rendering is done asynchronously.
Height measurement now uses a BlomURBEX service to obtain the best

angle in the oblique image to force the measurement in a vertical direction.

Better resize to avoid flickering.
Vector overlay on top of oblique imagery is done faster.
A new option in settings can change the priority order for the basemap.

Now it is possible to priorize between the different ortho images (“pictometry”,
“Countryortho” or “satellite”) present sometimes at the same zoom level in the
server.

Other tile layers in BlomURBEX server can be overlapped selecting them in

the options dialog.

Product and version number appears in “About” dialog.

Print error that occurred after printing is fixed.

Tooltips close when the map looses focus.

Default zoom and orientation has been fixed.

Views are now correct when changing between different layouts.

Bug fixed with double sync between map and BlomURBEX viewer.
Bug fixed with Extract image tool.

Proj4 DLL is no more used, but DotSpatial is used instead.

Installer uses bootstrap to download from web required prerequisites.
More accurate measurements in distance and area.
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Version 2.0 of BlomURBEX Plug-in for AutoCAD 2007/2008/2009
includes these improvements:

e Internet Explorer 7 not needed. New BlomURBEX viewer do not requires
Internet Explorer 7 to be installed or any other web browser. The Plug-in manage
requests on its own.

e A new image cache owned by all the Plug-ins speeds bitmap recovery and
makes it easy to manage the Plug-ins cache. No more the browser cache is used.

e Easier installation. BlomURBEX viewer component is not a previous install
requirement. Plug-in installer checks if viewer is installed, and if not, then installs
it. The viewer is never uninstalled to avoid other Plug-ins to stop working.

e Better performance. New BIomURBEX viewer is not JavaScript based but
.NET based, and executes code faster.

e New option to choose the date of the imagery, allowing to see history
changes in images, and seeing different years in a side-by-side mode.

e Year of the current visible image in a label at the bottom of each view.

¢ Intelligent behaviour when zooming. If a better view mode or orientation
exists for current zoom then it is loaded automatically.

e Faster vector overlay on obliques. The new BlomURBEX viewer sends
fewer requests to transform vector data between ortho and oblique, and draws
vector data faster.

¢ A new button in toolbar to enable/disable vector overlay faster than
changing settings.

e Print improvement. Print and export now support vector overlay.

e Log levels to better grained logging and a default folder for storing logs in
just one file.

e A new tool for extracting images has been added. If image exported is
ortho view, then the world file is saved for easy use in GIS packages.

e Proxy settings support

e Full support of Windows versions from XP to 7, including 32 and 64 bits
versions.

Blom, ASA. Proprietary
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3 System requirements

Microsoft .NET Framework 2.0 and 3.5 (installed by setup if not present)

BlomURBEX Plug-in for AutoCAD 2007/2008/2009 is developed with Microsoft
.NET Framework 2.0 and 3.5. During installation, if these Frameworks are not
present, they are downloaded and installed.

AutoCAD version 2007/2008/2009

This BlomURBEX Plug-in for AutoCAD 2007/2008/2009 requires any of these
products from Autodesk installed in order to execute BlomURBEX Plug-in.

Windows versions

BlomURBEX Plug-in for AutoCAD 2007/2008/2009 supports Windows versions
supported by the Autodesk product. Read AutoCAD 2007/2008/2009 install guide
for more info.

User Token

To access BIomURBEX Web Services a UserToken is needed. This UserToken is an
encrypted string that authenticates each user request. Contact with Blom
Marketing Department to obtain the required UserToken in:

http://www.blomasa.com/contact.html

4
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Installing BlomURBEX Plug-in for AutoCAD

2007/2008/2009

Ensure you are logged onto your computer with Administrator privileges.

Close all programs.

Uninstall previous “"BlomURBEX Plug-in” versions for any GIS or CAD package that

could be installed. Older “"BlomURBEX Plug-ins” cannot coexist with current

version. If any other Plug-in is installed for other GIS or CAD package, upgrade
the Plug-in also to last version.

4. Run setup.exe installer. Be careful to not run Urbex30AutoCAD2007.msi installer
because this installer does not check if dependencies are already installed.

5. If .NET Framework 2.0 or .NET Framework 3.5 are not installed a message is
shown. Accept in the message. The Frameworks will be downloaded from the
Microsoft webpage and installed.

6. If Microsoft Interop Forms is not installed a dialog will appear to perform its

installation. Click in Accept to accept the license agreement and continue. This

software from Microsoft is an add-in to the .NET Framework that improves

ActiveX / .NET interoperability.

WN =

" BlomURBEX plug-in 3.0 for AutoCAD 2007-08-08 Setup (5]

Far the following components:

Microsoft Interop Forms Redistributable Package 2.0a

Pleaze read the following icenze agreement. Press the page down kep to gee the rest
of the agreement.

MICROSOFT SOFTwWARE LICEMSE TERMS -
MICROSOFT INTEROPF FORMS REDISTRIBUTABLE PACKAGE 2.0 [l

These licenze terms are an agreement between Microzoft Corporation [or bazed
an where you live, ohe of itz affiliates) and you. Pleaze read them. They apply to
the zoftware named abowve, which includes the media on which you recerved it if
ary. The termgz alzo apply to any Microzoft

& updates,

# supplements,

¢ Internet-bazed services, and

# suppart services -

Wiew ELILA for printing

Do you accept the terms of the pending Licenze Agreement?

If you chooze Don't Accept, install will cloge. Toinstall you must accept this
agresment.

Acoept ] [ Daon't Accept J

7. Wait until Microsoft Interop Forms install completes.

Blom, ASA. Proprietary
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:;:j BlormURBEX plug-in 3.0 for AutoCAD 2007-03-09 Setup @

ij D owrloading required files...
o

Downloading file 1 of 1.

Cancel

8. The BlomURBEX Plug-in for AutoCAD 2007/2008/2009 Setup Wizard will lead you
through all stages of the setup process.

15! BlomURBEX plug-in 2.0 for AutoCAD 2007-08-09 =] @ =]
Welcome to the BlomURBEX plug-in 3.0 for
AutoCAD 2007-08-09 Setup Wizard =N 5 0OM

The ingtaller will guide you through the gteps required to install BlomJREEX plug-in 3.0 far AutoCAal
2007-08-09 on your compuker.

WARMING: This computer program iz protected by copyright law and intermational treaties.
Unautharized duplization ar distribution of this pragram, or any portion af it may result in severe civil
or criminal penaliies, and will be prosecuted to the maximum extent possible under the law.

9. Click Next > to begin installation.
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15! BlomURBEX plug-in 3.0 for AutoCAD 2007-08-09 o @ ([
License Agreement

ma BLOM

Fleaze take a moment to read the licenze agreement now. [F pou accept the terms below, click '
Agree”, then "Mext". Othenwize click "Cancel".

BELOM ASA it
END USER LICENSE AGREEMENT

MOTICE TO END TUSEE: CAEEFULLY EEAD THE FOLLCWITG
LEGAL AGEEEMENT. USE OF THE SOFTWARE PROVIDED
WITH THIS AGEREEMENT (THE “SOFI'WARE™) CONSTTITTES
YOUR ACCEPTANCE OF THESE TEEMS. IF YOU DO MOT
AGEEE TCO THE TERM: OF THIZ AGEEEMENT, PEOMPTLY
EETUEX THE SOFTWARE AWND THE ACCOMPANYING ITEMS -

| Do Mot Agree @ | Agree

| Cancel | | < Back | [ Mext = ]

10. The next screen displays the license agreement. Please read this and if you
accept the terms select the “I Agree” radio button. Click Next > to continue.

12! BlomURBEX plug-in 3.0 for AutoCAD 2007-08-09 o] @ [
Select Installation Folder
me BLOM
The inztaller will ingtall BElomlJREEX plug-in 3.0 for AutoCAD 2007-08-09 to the following folder.

Toinztall in thiz folder, click "MNext”. To install to a different folder, enter it below or click "Browse"'.

Folder:
C:%Program Files [#86])4Elom 254N\ lomUREEX plug-in 3.0 for AutaCh, | Browse. .. |

| Disk Cost. |

Inztall BlomlJRBEX plug-in 3.0 for AutoCAD 2007-08-09 for yourzelf, ar for anyone who uses this
computer:

@ Evenyone

Juzt me

| Cahcel | | ¢ Back | [ MHest » l

T ———— Y

11. Click Browse to change the destination folder. Click “Disc cost” to confirm that
there is enough space to install. Select in the radio buttons if BlomURBEX Plug-in

Blom, ASA. Proprietary
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for AutoCAD 2007/2008/2009 will be available to all users or just you in your
computer. Click Next > to continue.

15! BlomURBEX plug-in 3.0 for AutoCAD 2007-08-09 o B /[
Confirm Installation

mE BLOM

The installer is ready to install BlarlJRBEX plug-in 2.0 for AutoCAD 2007-08-03 on wour computer.

Click "Mext" to start the installation.

12. Click Next > to start installation.
13. Finally click Finish to close installation wizard.

Blom, ASA. Proprietary
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Starting with BlomURBEX Plug-in for AutoCAD

2007/2008/2009

5.1 Setup the BlomURBEX Viewer Plug-in in AutoCAD
2007/2008/2009

To execute the Plug-in, follow these steps:
1. Open AutoCAD 2007/2008/2009.

2. Select the Tools > Load application menu. The “Load / Unload applications” dialog
box will open.

Load/Unload Applications 21xl

W 5cconkl 7

File name: Iaccu:-nt'l 7 Load I

Files of bype: I.t‘-\utoC.i\D Apps [Cane" ks dvb; dbe T vl j

Loaded Applications | History st | I~ add to History
File | Fath |
acad.mnl C:ADocuments and Setlings'\manide._|

acad2007 L. C:A\Program Files\AotoCAD 2007%=0.

acad2007do...  C:A\Program Filesh\aotoCaD 2007:u,

AcApp.ars C:%Program FileshAutoCAD 2007

AcCamera.ars  C:\Program Files\AutaCAD 2007

accontl7.a  CAProgram Files\Blom ASANBlomU..
» I

EAPA TN | A Drmmr mes Cilmn A b= AT O Y
<

accont] 7. am successfully loaded.
Close | Help |

3. Browse for the accontl7.arx file contained in the Plug-in install folder, select it,
and then click the Load button. This ARX application is a utility that allows
dockable windows inside AutoCAD 2007/2008/2009. It should appear in the
bottom list of loaded applications, as shown in the screenshot.

4. To avoid this setup every time AutoCAD is started, click in the Contents button.
The “Load on startup” dialog box will appear.

9
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List of applications:

File [ Patn [
accont] 7. ar C:A\Program Filez'Blom A5a\ElomUREBEX ...

Add... Femove | Cloze | Help |

5. Click the Add button. A new dialog will open. Browse to the accontl7.arx file in
the Plug-in install folder, select it, and click Add. Then Close the “Load on startup”
dialog and the “Load / Unload applications” dialog.

6. To load the Blom Dockable Window that contains the BlomURBEX Viewer, type
with the mouse cursor inside AutoCAD or type in the command bar if visible the
following command: dockable_container and press Enter.

7. The command executes and asks for a ProgID (the identifier of the dockable
control that shows BlomURBEX Viewer). Type the following identifier:
BlomUrbexDock17.DockControl, and press Enter. After some seconds, the
BlomURBEX Viewer will be opened in a dockable window inside AutoCAD
2007/2008/2009.

Marne of control I::F'I"I:II;II:' ar |:|_':_II|:'::|:
S T T ]

8. It is possible to dock or undock the window as with any AutoCAD dockable
window. Also it is possible to reduce the window to a sidebar clicking in the
buttons that appear on top and title bar of the window. Also the window can be
closed. To open it again repeat steps 6 and 7. The window saves its state when
AutoCAD is closed so next time it will be seen the same as previously.

10
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5.2 Adding Data Sources

A Data Source is a repository of complex cartographic data. In order to work with
a Data Source it must be assigned to Plug-in.
Current version of Plug-in supports two different Data Sources:

1. BlomURBEX™ online services
2. Blom Libraries

5.2.1 Adding BlomURBEX™ as a Data Source

1. In the BlomURBEX Viewer toolbar, select the menu Settings > Open
settings dialog, to open the Settings dialog.

2. In the dialog select General tab.

3. In the Data Source drop down select “BIomprbex”.

General | La_l,u:uutl Linkingl Printingl Savingl Owerlays

Data source: I BlorlJREBEX j

BlamlIRBE: SEWE’BIDm Library

11
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4. In the “User token” textbox type the UserToken provided by Blom. This
UserToken is an encrypted string that authenticates each user request.
Contact with Blom Marketing Department to obtain the required
UserToken. The UserToken is needed to connect to the BlomURBEX Web
Services and allow the access to the imagery.

General | La_l,loutl Linkingl F'lintingl Savingl Dverlaysl

Data source IBIDmUHBEX 'I

Uszer Taker:

Bazelayer priority

Ipictometry,countr_l,lolthn,satellite

Units ————— Select interface language: Log lewvel:
{® Meters IEng|i3;h j INone j
" Feet
Delete cache |
Open... | Save.. | 0K Cancel

5. Click OK button to finish configuration.

5.2.2 Adding Blom Library as a Data Source

1. In the BlomURBEX Viewer toolbar, select the menu Settings > Open
settings dialog, to open the Settings dialog.

2. In the dialog select General tab.

3. In the Data Source drop down select “Blom Library”.

General | La_l,u:-utl Linkingl F'rintingl Savingl Oeverlays I 8

Data source: Blom Library j
BlomJREE

4. Selecting Blom Libraries
* Browse and select a Blom Library.
= Click “add new” button in order to add multiple libraries.
5. Selecting Library Licenses
* Browse and select a valid License.
= Click "Add New” button in order to add multiple licenses in case
there are more than one library.

12
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6. In order to remove a Library or a License, click delete button next to it.

General | Layout | Linking | Frinting | Saving | Overlays |
Datasowce: [Blom Library |
Blom libraries Licenses
x| x|
k= add new ks add new

7. Click OK button to finish configuration.
5.3 Setup the BlomURBEX Viewer basic options

The first thing to do in an application that uses BlomURBEX Viewer is to specify
some minimum options in order that the viewer can correctly search for images.
For this follow the next steps.

1. Open BlomURBEX Viewer window using the dockable_container command

as explained above.
2. In the BlomURBEX Viewer toolbar select the menu Settings > Open

settings dialog to open the Settings dialog.

Settings = ? =

|E’ Open settings dialog.. . |

S Language b
Layout »

3. In the dialog select the General tab. Select the desired Data Source (See
section 5.2 for details on adding a Data Source).

4. Select the Linking tab. Depending on the projection of the basemap (the
map of AutoCAD 2007/2008/2009) it is needed to indicate BlomURBEX Viewer
which projection is this. Follow next steps.

13
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aE BLOM

Generall Layout  Linking | F'rintingl Savingl Dverla_l,lsl

¥ Dizplay image visible extent on linked mapping application

¥ Display image total extent on linked mapping application

¥ Center linked map at main view center

™ Center main views at linked map center

Projection in the map of the linked application:

|WGS 04 [EPSG:4326] Select... |

Save locatioh measurements
£~ in Spherical Mercator projection

& in selected map projection

Open... |

Save... | oK | Cancel |

5. Click in the Select button to open the “Select projection” dialog. In the
dialog select in the available projection list the one that the basemap has. There
are different options to select the desired projection:

6. To select a projection from the full list of supported projections, choose
“Show all projections” in the upper dropdown box. To select click in the list and
then click in OK, or double click an item in the list. Any item chosen will be
reminded later in a list with the most used projections, so it is not needed to find
it again in the long list. Also, it is possible to add any item to this "most used” list
without leaving the dialog clicking with right mouse button and selecting “"Add to

most used” from the context menu.

Seleckt projection

Enter a ward ta filter related projections: I Filker |

EPSG Code | Mame | FF=
40 dnknown datum bazed upan the A 1830 elipsoid e
4002 Unkrnown datum bazed upon the Ain Modified 1849 elipzoid — +¢
4003 Inkrnown datum bazed upon the Australian Mational Spher.. 4
4004 drnknown datum bazed upan the Beszel 1847 elipzoid +[
4005 [Inknown datum bazed upon the Beszsel Maodified ellipsoid +[
4006 IInkrnown datum bazed upon the Bessel Mamibia elipzoid +[
4007 nknown datum bazed upon the Clarke 1858 elipzoid +[
4003 [Inknown datum bazed upon the Clarke 1366 elipsoid +[
4009 Unknown datum bazed upon the Clarke 1866 Michigan ell...  +f
ama nknown datum bazed upon the Clarke 1880 [Benoit] elip..  +f
4011 Unkrnown datum bazed upon the Clarke 1880 [IGM] elipsoid — +f
4mz Urknown datum based upon the Clarke 1880 (RGS) elipsoid — +p
A1 2 I Lindlssmminnim A=biirn bommmd simmin Hem Tlmele = 100000 T e sl AllimmmiA '
4 r [

ak | Cancel |
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Select projection

IShu:uw all projections j

Enter a ward ta filter related projections: I Filker |
EPSG Code | Mame | PR |
32625 WG5S 84/ UTHM zone 26M +
32626 WG5S 84 / UTHM zone 26M +
2627 WG5S 84/ UTM zone 27M +
32628 WG5S 84/ UTHM zone 28M +
32629 WG5S 84/ UTHM zone 29M +

e Ty

Add to most used

32632 WES B OTH zone 32H +F
32633 WG5S 84/ UTH zone 33M +
32634 WiES 84/ UTH zone 34N +
32635 WiES 84/ UTH zone 35M |
32636 WG5S 84/ UTH zone 36MH +,
2 s Od M IThd amimm TR '

3 I

7. To select a projection from the reduced list of the most used projections,
choose “"Show most used projections” from the upper dropdown box. The list will
show only those projections selected at least once or any other marked explicitly
as “most used”. To select click in the list and then click in OK, or double click an
item in the list. Alternatively, it is possible to remove items from this *most used”
list clicking with the right mouse button and selecting "Remove from most used”.
The current selected projection cannot be removed from this list.

Select projection

Show most uzed projections
Enter a ward to filker related projections: I Filter |
EPSG Code | Name | PROJ &
4326 WwWiEs 84 +proj:
2630 WiES 84 A UTH zone 30M +proj:
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Select projection

IShu:uw mozt uged projections j
Enter a word to filker related projection:s: I Filter |
EPSG Code | Mame | PROJ

A 4| LTk zoune AR

Remove From most used

1| | i

Cancel |

8. To select a projection from a reduced list using a filter, choose “Use a
filter” in the upper dropdown box. The filter textbox and Filter button will
activate. Type a search word or words in the filter textbox and press Filter. Only
the projections containing the full search text will be shown. The search is
possible by EPSG code and also by the projection name, and is case insensitive.
To select click in the list and then click in OK, or double click an item in the list.
The selected projection will be recorded in the “"most used” list as usual.

Select projection
I IJze a filker j

Enter a ward ta filker related projections; Iu:usgl:u Filter |

EPSG Code | Mame | PROJ
4277 O5GE 1936 e
4278 OSGETD e
27700 OSGE 1936 / British National Grid +praj

1 | i

Cancel |

9. Save the settings clicking in OK. Settings are saved in registry for each
user so it is not needed to set them again later as each user has their own
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settings. The latest settings are used by default. To configure different settings
use the Save button to save a file with the settings that can be later opened with
the Open button.

10. This finish the configuration.

Settings do not persist, if the Plug-in is reinstalled. We need to set the settings
@ again in case of re-installation.
5.4 Changing language interface

Language interface can be changed through the direct menu: Settings >
Language, or through the Settings dialog, by Settings > Open Settings dialog.
The first is a more direct way to change the language, but the results are the
same.

To change the language through the direct menu:

1. Click in menu Settings > Language > <The desired language>. The
interface language of the application is changed at once. The selection is saved in
the user registry so next time BlomURBEX Viewer is opened the preferred
language will remain in the interface.

Settings ~|? -

E Open settings dialog. ..

|_;', Language » |E| English
Layout 4 Espafiol

Deutsch
Francais
Italiano
MNederlands
Portugués
Dansk
Morsk
Swvenska

Suomi

Romana

To change the language through the settings dialog:

1. Click in menu Settings > Open settings dialog.

2. Select the General tab. In the Language selector, choose the preferred
one. The interface language of the application is changed at once.

3. If needed, click Save to save the settings in a file for future use.

4. Click OK to save the settings in user registry. Next time BlomURBEX
Viewer is opened the preferred language will remain in the interface.

Improving translations of the interface is very easy. Check the Appendixes.
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General | La_l,loutl Linkingl F'lintingl Savingl Dverla_l,.lsl

['ata source IBIomUHBEX 'I

Uszer Taker:

Bazelayer priority

Ipictometr}l,countr}lolthn,satellite

Units ———— Select interface language: Log level:
{* Meters IEng“gh j INone j
" Feet
Delete cache |
Open... Save... | 0K Cancel

5.5 Changing layout

BlomURBEX Viewer can show one or several orientations at the time using
different layouts, and view images of different dates. It is possible to change from
one layout to other either from Settings > Layout direct menu, or using the
Settings dialog by Settings > Open settings dialog menu. The first is a more
direct way to change the layout, but the results are the same.

To change the layout using a direct menu:
1. Click in Settings > Layout > <the desired layout>. The choice is saved in

the user registry so this layout will remain in future sessions until changed again.

Settings ~|? -

E’ Open settings dialog. ...

5 Language 3

| Layout 4 H7| Single view

Dual view
Three views
Four views

Penta view
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To change the layout and image dates using the settings dialog:
1. Click in Settings > Open settings dialog menu to open settings dialog.

General Layout ILinkingI F'rintingl Savingl Dverlaysl
Layout of the views and pear for the images: IThree Views j
Fle - £ & (@ Q [xr L D B &H]E :
|
|2DDB-20EIB
|2DDS
M Main view
Open... Save... 0k Cancel

2. In the dialog select the Layout tab and select the preferred layout in the
upper dropdown box. For each view in the layout, it is possible to select the
preferred year of the BlomURBEX imagery to be shown as explained later.

3. If needed, click Save to save the settings to disk for future use.
4. Click OK to save the settings in user registry. Next time BlomURBEX
Viewer opens the preferred layout will remain in the interface.
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6 Viewing BlomURBEX images

The BlomURBEX Viewer is the window that shows BlomURBEX images. To open
an image is needed to select a location, either clicking in the basemap in AutoCAD
2007/2008/2009 or introducing a known coordinates.

6.1 Selecting location in AutoCAD 2007/2008/2009

Open AutoCAD 2007/2008/2009 with a basemap.

Open BlomURBEX Viewer if it is not, as explained previously.

Ensure that settings are correct, as previously indicated.

Resize and move application windows so they can be seen comfortably.
Open any map data in AutoCAD 2007/2008/2009. The data can use any
prOJectlon if it is in the EPSG list in the BlomURBEX Viewer options. It is only
needed to know the projection and to indicate this projection in the BlomURBEX
Viewer settings dialog.

A

@ Remember when using different drawing files in AutoCAD with different projections
to modify the options in BlomURBEX Viewer matching the active one.

1. Once everything is right set, and with a map drawing opened, click in the “Center
in new map point” button at the bottom of the BlomURBEX Viewer. Click OK in
the message that appears and then move mouse cursor over the map display and
click inside it. A message requesting a point will appear. Type the exact
coordinates and press Enter or select a point clicking in the map.

Center in new map point

2. After some seconds BlomURBEX Viewer will open the best Blom images for that
location, in all the orientations selected in the BlomURBEX Viewer layout. The
images are centered in the selected point and show a crosshair. If no image
appears consider if your user permissions do not allow seeing images for that
location.
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6.2 Introducing known coordinates in BlomURBEX Viewer

xx

1. In BlomURBEX Viewer toolbar click in the tool “"Go to coordinates...”
The “Go to coordinate” dialog is opened.

Go to coordinate

# oor Longitude:  |NSeFgalss

¥ or Latitude:  |40,655627
[EDSD [EPSG:4230] Select... |

oK | Cancel |

2. Introduce a correct longitude or X and latitude or Y coordinates. Indicate
the projection for this coordinates clicking in Select. This opens the same Select
projection dialog that we see when selecting the basic options. By default, the
last projection selected in the Settings dialog is offered here, but it can be
changed, so we can ask for coordinates in any of the supported projections.

3. Click OK.

4. After some seconds BlIomURBEX Viewer will open the best BlomURBEX
images for that location, in all the orientations selected in the BlomURBEX Viewer
layout. The images are centered in the selected point and show a crosshair. If no
image appears consider if your user permissions do not allow seeing images for
that location.

6.3 Panning images

“Panning” is the default behaviour of the display when no tool is selected.

1. In BlomURBEX Viewer unselect any tool in the toolbar.

2. Click and hold the left mouse button in the view to pan.

3. Drag the image up, down, left, or right within the view, and finally release
mouse.

6.4 Magnifying images

It is possible to zoom in for more detail or zoom out for more context information.
Simply change the image’s magnification by using the zoom buttons on the
toolbar.

Zooming in all views

Use the “Zoom In” button to increase the magnification of an image.
To zoom in:

&)
1. Click the “"Zoom In” button on the toolbar )
2. The magnification percentage is doubled. (The part of the image that was
centered in the display remains in the center.) . The "Zoom In” button affects all
the images opened in the layout.
3. Continue clicking the button until reached the desired amount of
magnification.
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Zooming out all views

1. Click the “Zoom Out” button on the toolbar . The “Zoom Out” button
affects all the images.

2. The magnification is reduced by half.

3. Repeat Step 1 until zoomed out the desired amount.

Zooming in or out with the mouse wheel in one view

1. Move the mouse wheel frontwards or backwards to zoom in or out in just
one view.

Zooming to a extent in one view

1. Unselect any tool selected in the toolbar so the “"Pan” default tool
activates.

2. Press SHIFT key in keyboard.

3. Click with left mouse button in any view and hold pressed. Drag to draw a
rectangle. A rectangle appears showing the extent selected. Release button at the
ending corner.

4. Map centers and zoom to the best level zoom that contains the selected
extent. This action only affects the view used.

Zooming with the zoom bar in one view

1. Each view has a zoom bar with a “+” button on top and a “-" button on
bottom. Click “+" button to increase the zoom level, or “-"” to decrease the zoom
level. There are 20 zoom levels available for the “continuous” or “Ortho” view
mode (see below about view modes). There are 6 zoom levels available for the
“photo by photo” or "Oblique” mode. The last two levels in “"Oblique” mode are a
resample of level 4.

2. Alternatively drag the level indicator up or down to increase or decrease
any number of zoom levels. Every view in the layout has its own level indicator,
so changes in this only affect the view that contains that level indicator.
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6.5 Changing views

Initially each view in the layout has set an orientation, but it is possible to modify
this selecting orientations orientation selector. In fact, it is possible to have the
same image several times. For example, it is possible to use the dual view to
have two times the same ortho image opened. It can be useful to have a master
- detail view to study two distant buildings at the same time that are in the same
photo. Each time an orientation is changed in a view; this setting is saved in user
registry so it will be used until changed again.

There are two types of view modes: “Ortho”, that shows the images in a
continuous mode, and “Oblique”, that shows images one by one. In both modes it
is possible to do “"Pan” in the map endlessly. In the Obligue mode a new image is
loaded in a seamless way when “panning” reaches the border of the current
loaded image.

due to the irregularities of the terrain model that affects the ortho-rectification

Oblique imagery shown in a “continuous” or “Ortho” mode may suffer some distortion
; process. In flatter terrains the distortion is less.

@ Tools are unselected when the view mode changes. Remember to select again the
tool if using one when the mode is changed.

There are five types of orientations: “Ortho” orientation, that shows the image as
an ortho-photo; “North”, that shows the image looking from south to north;
“South”, from north to south; “East”, from west to east; and “"West”, from east to
west. To change the orientation click in the “0”, "N”, *S”, “E"” or "W” buttons in
the upper left control to activate the “Ortho”, “"North”, “"South”, “East” and “West”
orientations, respectively.

The size of each view in the layout can be changed through the use of splitter
bars between the views. Just move the mouse in the boundary of two views, and
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when the cursor changes, drag and drop the splitter to change the size of the
views. Each time the size is changed this setting is saved in the user registry.

6.6 The intelligent behavior

At closer zoom levels, oblique rectified images show big distortion on the
buildings, while at furthest zoom levels they do not offer better information than
the ortho images.

Each view in the BlomURBEX Viewer is configured in an intelligent way so that
any request that attempts to change the zoom level of the view will check if the
view is displaying any orientation other than Ortho, and in this case decide what
set of images should be displayed: ortho, oblique rectified or natural obliques.

6.7 Changing basemap ortho image

By default the ortho image shown as basemap is one from several images
available in BlomURBEX server. These images are visible are certain resolutions:

e Satellite images, with low resolution of the data. This source data is
available in the furthest zoom levels (1 to 13), and contains Blue Marble and
Landsat 7 imagery.

e Countryortho is imagery covering a whole country (or a region). This
source data is available in the medium zoom levels (13 to 19), and contains
imagery from several providers and from Blom.

e Blom imagery captured with Pictometry cameras, also called “pictometry”

images in the BlomURBEX server. This source data is available in the zoom levels
with the maximum resolution (14 to 20).
As can be seen at certain zoom levels these three sources coexist. For that zoom
levels with more than one image available, the BlomURBEX server prioritizes first
the “pictometry” image, then the “Countryortho”, and finally, the “satellite”. It is
possible to change this priority in the options.
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Baselayer priority Baselayer priority

pictometry,countryortho,satellite countryortho, pictometry, satellite

In the textbox “Baselayer priority” of the General tab of the Settings dialog,
change the text to consider other priorities in the images for the basemap. For
example, in the next screen capture, the left shows the default priority with the
“pictometry” imagery by Blom in the zoom level 18, and the right shows a
different priority that renders the “Countryortho” imagery, that is also available
for that zoom level.

will be shown. Type the names separated by commas and without any blank
spaces.

@ Be careful to type the correct names in the Baselayer priority textbox, or no image

6.8 Showing the visible and total extension in AutoCAD
2007/2008/2009

It is possible to see the visible and total extent of the opened BlomURBEX images
drawn in AutoCAD 2007/2008/2009. To do this follow this steps:

1. In BlomURBEX Viewer, select the menu Settings > Open Settings dialog. In the
Settings dialog select the Linking tab. Ensure that checkbox “Display image
visible extent on linked mapping application” is checked for viewing the visible
extent, and that checkbox “Display image total extent on linked mapping
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application” is checked for viewing the total extent. Uncheck the checkboxes to
not update the extents in AutoCAD 2007/2008/2009. The total extent only has
sense when the view mode is “photo by photo” also called “"Oblique” mode.

¥ Display image wisible sxtent an linked mapping application

¥ Dizplay image total extent on linked mapping application

2. Modify the visible extent of BlomURBEX Viewer by panning or zooming in the
current image, or requesting other image.

3. After a moment the boundaries will be drawn in AutoCAD 2007/2008/2009.
Boundaries are drawn using two layers in AutoCAD 2007/2008/2009. By default
visible extents are drawn in the color with index 3 in the current color table and
total extents in the color with index 1. Modify this color indexes to show the
extents in better colors. Ensure that the current colors do not match the
background color or extents will not be visible. Also ensure that these layers in
AutoCAD 2007/2008/2009 are visible and are rendered using colors by layer.

4. Another way to avoid the refresh of the visible an total extent, and also to avoid
the refresh of the red crosshair with the center, is to set the appropriate layer to
not visible in the Layer Properties Manager once this layers are added to the
AutoCAD drawing.

@Layer Properties Manager

2 _I ik..,l X| Jl |Current layer: 0
= Al Stal] Mame | On | Freeze | Lock| Color | Linetype | Lineweight | Flot St_l,lle | Plot| Dest
t‘E Alllsed Layers v 0 @] My [ white Coentinuous —— Default Colo

% [BlomUrbExSelectedPoint | ? fig Ored Continuous — Default
% BlomUrbExTotal Extent | fig O blue Continuous —— Default

% BlomUrbExVisibleExtent ] M O red Continuous —— Default

6.9 Synchronizing views

It is possible to synchronize the several views in the BlomURBEX layout, and
synchronize the main view in BlomURBEX with the linked map in AutoCAD

2007/2008/2009. To do this follow this steps:
1. Open the Settings dialog and select the Linking tab.

™ Center linked map at main view center

—

™ Center main view at linked map center

To update AutoCAD 2007/2008/2009 map center when BlomURBEX main view
changes:

2. The main view in BlomURBEX is one of the opened views. Depending on
the layout the main view changes. The settings dialog marks which is the main
view for each layout type. This view can be in sync with the linked map
application. For it check the “"Center linked map at main view center”. Now each
time the location of the BlomURBEX main view changes, the map will be
refreshed to show that location.
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6.10

To update the main view in the BlomURBEX layout with AutoCAD
2007/2008/2009:

3. The main view in BlomURBEX is one of the opened views. Depending on
the layout the main view changes. The settings dialog marks which is the main
view for each layout type. This view can be in sync with the AutoCAD map. For it
check the “Center main view at linked map center”. Now each time the center of
the AutoCAD map changes, BlomURBEX main view will be refreshed to show that
location.

Seeing historical images from different years

It is possible to show imagery for different years in each view, facilitating user to

follow the changes occurred in a spot of the city. To do this, follow these steps:

1. Open the Settings dialog and select the Layout tab.

2. For the current layout, a set of textboxes for each view is shown in the
dialog. Enter a year or a range of years, inside these textboxes to filter that view
for a particular point in time. The date filter should follow one of these structures:
YYYY-YYYY and YYYY, where YYYY is the year number with four digits.

3. For example: “"2005-2008" will return the most updated image available
inside the range of years, including both bounding years. In this example, if an
image of 2007 is available and no image in 2008 is available, then the image of
2007 is returned. But if no image is available between 2005 and 2008, and only
an image of 2009 is available, then no image will be returned.

4. Another example: “"2006” will return the most current images available,
whose date is previous to the requested date. In this case if several images are
available previous to the year 2006 or from that year, then the last one will be
returned.

5. If the default value is empty, then the most updated image will be
requested.

6. If a wrong value is sent, then no image will be returned.

7. The settings will affect also the Extract image or Export image tools when
applied to the views with a date filter.
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General  Lavout | Linkingl F'rintingl Savingl Dvetlaysl

Layout af the views and vear for the images: IThree views j

-S4 aQ UDBOHE 2
n

T
| =

|2I:II35

W Main view

Open... Save... 0k Cancel
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IMNG THE WORLD

Above both views of Eiffel tower from 2008 and 2009

The option to change the date of the BlomURBEX images allows to see side by side
the same part of a city in different years. Up to five different years could be shown
at a time. Just select the same view mode and orientation, and explained below,
for each view in a multi-view layout, but choose different years for each view.
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To obtain the information about the current opened image, click in the Image
Properties button in any status bar of the views. A panel will open showing extent
coordinates in WGS84 lon/lat for the full image (in obliques) and for the visible
portion and other data if available. To hide the panel click again in the button.

Vizible extent polygon:

Upper Left Shot Corner: oo=4 7010423659347 2, 40 E502071933321 [WEE 24])

Upper Right Zhot Corner: D -4.63742030226358, 40 6LDEQTL19233232] [WEE 24]
Lower Right Shot Corner: D -4, 6974B8039236358, 40.647866915731 [WES 841

Lower Left Shot Corner: D=4 701042368234 72, 40 647266918791 [WEE 24]

Twage Orientation: Ortho

Info in ortho view

Image Size: 4008xE672 (pixel)

|Full extent polygon:
Left Shot Corner: : -4 703294095, 40.6534E541844 [WGEE 84]
Dight Shot Corner: D -4.6940387618, 40_8EZETZ2E7E5 [WEE 241
Bight Shot Corner: : -4 6951035487, 40_8467559883 [WEE 54]
Left Shot Corner: D —4.70193002732, 40.8471985112 [WEE 24]

BUizible extent polygomn:
Upper Left Shot Corner: @ -4.70265737314148, 40_.65Z1538667807 [WEE 241

Info in oblique view

To copy the image data just select the text in the panel, click the right mouse
button, select copy, and paste it anywhere.
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8 Using the measurement tools

BlomURBEX Viewer offers various tools for measuring features visible in images.
For example, it is possible to measure the distance between two points, the
elevation of the terrain, building heights, bearing, area, perimeter, and the
coordinates of a point.

Before using the measurement tools, be sure that the unit of measure is set as
desired.

8.1 Changing units of measure
To change units of measure:
1. In BlomURBEX Viewer click the menu Settings > Open Settings dialog. The
Settings dialog box opens.
2. In the General tab click the desired units: Meters or Feet.
3. Click OK.
The changes remain in effect until units are changed again.

8.2 Viewing the coordinates of a location

Use the Location Tool to determine the location (the coordinates) of an object in
an image both in ortho or oblique views.

To determine the location of an object:

1. In BlomURBEX Viewer click the Location Tool =1,

2. Click the desired location on the image.

3. The point’s coordinates appear drawn in the view. If the projection selected in
the Settings dialog is not Spherical Mercator, the same coordinates will be
seen in both systems, Spherical Mercator and the selected one, in the desired
units, meters or feet.

@ For Oblique images, remember to click near the base of buildings for more
accurate coordinates.
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8.3 Measuring squared perimeter or distance

Use the Distance Tool to measure perimeter—the distance around the outside
edge of an object or distances both in ortho or oblique views.

To measure perimeter by using a parallelogram or measure distances:

1. Click the Distance Tool =D= .

2. Starting with one corner of the object, click with the left mouse button.

3. Click again for each new vertex. The outline of a polyline appears as new
vertexes are added. In oblique mode take in mind that a workaround to the
server must be done in each vertex and the measure takes longer.

4. When the polyline surrounds the shape being measured or distance being
measured, double click with left mouse button.

5. The partial measurements and total length appears drawn in the view.

8.4 Measuring bearing

Use the mouse to draw one line to measure bearing both in ortho or oblique
views. Where start drawing the line is important, as shown in the following
illustrations:
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To measure bearing:

Click the Bearing Tool E

1.

2. Click with the left mouse button on the starting point.

3. Click with the left mouse button on the ending point in the direction you
want to measure the bearing of. The measurement appears drawn in view.

8.5 Measuring area

The Area Tool lets to measure the area of any linear shape both in ortho or

oblique views. After the perimeter of the area to be measured is outlined, the
area measurement appears in view.

To measure the area of any straight-sided shape:
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1. Click the Area Tool ﬂ'——l .

2. Click in the display at the desired starting point.

3. Click again for every new vertex of the area. A polygon that returns to
initial point is drawn automatically.

4. When outlined the entire perimeter, double click in the last vertex.

8.6 Measuring height

Use the Height Tool to measure the height of an object in an Oblique image.
(Because orthogonal images are captured straight down, the Height Tool doesn’t
apply to the “continuous” or “"Ortho” view mode.)

To measure height:

1. Click the Height Tool @
2. Click with the left mouse button on a point at the base (where it meets the
ground) of the object we want to measure the height of.

@ Important: Be sure to measure height by starting at ground level and moving
upwards. If the ground level starting point is not seen, then estimate its location.

3. Move the mouse upwards and click a new vertex at the ending point.
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4. The measurement appears drawn in view.

8.7 Measuring elevation

Use the Elevation Tool to measure the elevation (height above sea level) of a
point in an image.

To measure the elevation:

O

1. Click the Elevation Tool b=,
2. Click the point whose elevation to measure.
3. The measurement appears drawn in view.

8.8 Clearing measurements

Use the Eraser Tool to clear measurements in the map display.

To clear measurements:

1. Click the Eraser Tool '5:2
2. The measurements are removed in all available views.
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9 Printing images

BlomURBEX Viewer let print all the views opened to the selected printer, setup
the page options and preview the printing, along with the image properties if they
were activated in the settings dialog. Before printing, scroll or pan the image so
that the portion we wish to print is visible in the display. Also resize the views
with the splitters and the size of the BlomURBEX Viewer window. The visible
portion of each image, and with the exact pixel size, will be send to printer.

9.1 Printing images

To send all the current views to the printer with the current settings:
1. Click the File > Print menu.

Fe|S & @ Q |x LD

H
z
Export image. ..
Stark saving measurements

Print. ..

Prink presdew, .,

Page setup...

o ko[l &

2. The views are printed.
Each view in the layout is printed in different pages also with the image
information activated in settings. If the image information is longer than the page
space, it will be cropped. In this case, try reducing the size of the BlomURBEX
Viewer views or window, or limit the amount of information to print in settings

dialog, as explained below.

9.2 Changing print settings

To change the printing settings:

1. Click the Settings > Open Settings dialog menu.

2. The settings dialog opens. Select the Printing tab.

3. Check or uncheck the options wanted.

4. “Display image properties” adds the corner coordinates of the image to the
output (if the image is a oblique one) and other properties.

5. “Display the visible extension of the image” adds the corner coordinates of
the visible portion of the image.

6. “Display shot date” adds to the output the shot date of the image.

7. Click OK in the Settings dialog to save changes.
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Generall Layoutl Linking ~ Printing | Savingl Uverlaysl

v Display Image Properties
[V Display the vizsible extension of the image

¥ Dizplay Shot Date

Open... Save... Ok Cancel

9.3 Page setup

To change page settings:
1. Click the File > Page setup menu.

Fe-lg @ @ |x L DE

Expart image...

trd  Start saving measurements

= Print...

& Print preview...

0 Page setup...

2. The Page setup dialog opens. Modify the page margin, orientation, etc. as
desired. Click OK to accept changes.

9.4 Print preview

To preview the print:
1. Click the File >Print preview menu.

[Fie -|& & |® @ |xr L| D, B

Export image...

@ Start saving measurements

= Print...

|__‘L Print preswiew. ..

i

Page setup...
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2. The Print preview dialog opens. Click in the options to see the print at
different zooms o layouts. Also it is possible to print clicking in the Print button.
The dialog can be resized to full screen.
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The image shows the preview of a dual view layout. Each view and its properties are
print in different pages.
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10 Exporting images

10.1 Exporting all visible views

The BlomURBEX Viewer “Export image” menu lets exporting the visible extent of
the active views to a set of JPG files.

To export an image:
1. Pan in the views to display the extent desired.
2. Click the “File > Export image...” menu.
3. In the Save as dialog that opens introduce the path and filename for the
file.

The extracted image or images are saved with the filename specified. If the
BlomURBEX layout shows several views, then several files will be created and all
the files will be suffixed with a view number and orientation. Also, if view is in
ortho mode, a world file (JGW) is saved for easy integration of the image in other
GIS packages.

Fe-|Z G @ Q[x L DE

| Export image. ..

Stark saving measurements

Prink. ..

Prink presview. ..

=kl &

Page setup...

10.2 Projection of the extracted ortho images

The projection of the extracted ortho images are “Spherical Mercator”, the
projection labelled by EPSG as 'Popular Visualisation CRS / Mercator' in March
2008 with code number 3785. Due to limited support to this projection in
AutoCAD 2007/2008/2009 version, a transformation of the exported images using
other software would be necessary to open them in AutoCAD 2007/2008/2009.
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11 Saving measurements

BlomURBEX Viewer is able to notify when the user has made measurements in
order to store this measures into any opened table in AutoCAD 2007/2008/2009.

11.1 Setting measurement savings

To activate the measurement storage, it is needed to complete two one-time
setup tasks. It is needed to specify some options about the place where store the
measurements, and some options about the units and the projection to use (in
the case the measurements are locations).

To specify the options regarding the place to store measurements:
1. Click in the “Center in new map point” button once. When this button is clicked,
the Saving options are updated for the current drawing opened.
Click in the Settings > Open Settings dialog menu.
The Settings dialog opens. Select the Saving tab.
Select a mode for saving measurements from the Table dropdown list. The
options for saving measurements are: “<Save as text>", that inserts a text with
the measure; “<Save as dimension>", that creates a dimension (only has sense
for linear or angular measurements); “<Save as attribute>", that creates a block
with the measurements as attributes; “<Save as extrusion (only for Heights)”,
that saves the measurements as Z values inside the geometry (only has sense for
height measurements).

HWN

Generall Layoutl Linkingl Printing ~ Saving | Dverlaysl

Optiong for zaving measurements:
Table: Heights =l
. <Mone>
Calurnn far aress: Cave o borts
’ <5 ave az dimension>
Calurnt far distances: <Cave a5 athibutes
. <Save a3 extrusion [only for heights]>
Calurnn Far keights: L=t =
2
Calumn for elevations: IEIe\-'ation i
Columnn for ¥ coords: |>< j
Columnn for v coords: IY j
Colurnn far bearings: IBearing j
Open... | Save... | ak | Cancel |

5. Each option of the Table dropdown list populates different sub-options in the
Column dropdown lists:
e For “"Save as text” mode, only a "<Save as text>" option is given. Select this
sub-option for that type of measurements you want to save as texts, and
leave as “<None>" for that measurements not to be saved.
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e For “Save as dimension” mode, two sub-options (Linear dimension and
Angular dimension) are given. Select “Linear dimension” for distances and
heights measurements, and select “"Angular dimension” for bearing
measurements, because for the other type of measurements this saving has
no sense.

e For “Save as attribute” there are multiple sub-options, one per each type of
measurement. In this last case the sub-options represent names for blocks
and attributes that will be added to drawing for storing the measurements.

e For “Save as extrusion (only for heights)” mode, only a sub-option “Save as
extrusion (only for heights)” is given. Select this sub-option for height
measurements only. This option will extrude one or several region objects
selected.

6. As seen in the screenshot, it is possible to select a sub-option from the dropdown
lists for each type of measurement to save. It is possible to store seven different
type of measurement. The table summarizes the relation between the
BlomURBEX Viewer tools and the Column dropdown used to make the savings.

In BlomURBEX Viewer In AutoCAD 2007/2008/2009 measurements are saved in
the tool used is ... the field selected in dropdown...

A7 Column for areas

2, Column for distances

H] Column for heights

oh Column for elevations

L Column for X coords and Y coords

B~ Column for bearings

7. To store only some measurements, select <None> for those
measurements in the dropdown lists.
8. Click in OK to save settings.

To specify the options regarding the units and the projection to use in locations:

1. Click in the Settings > Open Settings dialog menu.

2. The Settings dialog opens. Select the Saving tab.

3. Select the desired units, meters or feet. The values will be stored in the
units selected.

4. Select the Linking tab.

5. 1In the “Save location measurements” groupbox, choose “in Spherical
Mercator projection” for storing location data in Spherical Mercator meters in
AutoCAD 2007/2008/2009, or choose “in selected map projection”, more usual,
for storing location data in the projection of the current map in AutoCAD
2007/2008/2009. This setting only affects the Location tool.

6. Click OK to save settings.
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Projection in the map of the linked application:

|WGS 84 [EPSG:4326) Select... |

|’ Save location measurements

" in Spherical Mercator projection

& in selected map projection

11.2 Starting and stopping save sessions

11.3

In BlomURBEX Viewer it is possible to start, pause and continue the savings
through an option.

To start a save session:

1. Click in the “File > Start saving measurements” menu if it is unchecked.
The menu will toggle to a checked state and measurements will be stored (if
fields were correctly set).

To pause a session:
1. Click in the “File > Stop saving measurements” menu if it is checked. The
menu will toggle to an unchecked state and measurements will be paused.

Fe-|S F @ Q[xrL DE Fie -|Z & R QXY L D §

Export irmage. .. Export image...

|gﬂ Start saving measurements | Stop saving measurements | i
1

Prink. .. Print...

Print presiew. .. Print preview, ..

o k& W [E]

B o WL

Page setup... Page setup...

Procedure for saving measurements

The procedure for saving measurements is this:

Ensure that the “Start saving measurements” menu is checked so the text in the
menu is now “Stop saving measurements”.

Now in BlIomURBEX Viewer do a measurement as described in this manual. A
message to confirm the saving appears, informing about the measurement that is
going to be saved, and the method and sub-option to be used. Click “Yes” to
proceed.

An input box appears, for methods “Save as text”, "Save as dimension” and
“Save as attribute”, to define a text height in map units that will be used to draw
texts in AutoCAD. Type a height value and click OK.

Click in the map display to activate the AutoCAD commands.

If the mode for saving was “Save as text”, the user will be prompted for a point
where to insert the text. Enter a known coordinates and press Enter or click a
point in the map.

If the mode for saving was “Save as dimension” and the sub-option was “Linear
dimension”, the user will be prompted for a point where to start creating the
dimension. Enter a known coordinates and press Enter or click a point in the map.

43

Blom, ASA. Proprietary



e BLOMURBEX e oY

BIomURBEX™ Plug-in for AutoCAD 2007/2008/2009 v3.0.0

11.4

Next the user will be prompted for a point where to finish creating the dimension.
Enter a known coordinates and press Enter or click a point in the map. Finally the
user will be prompted for a point where to position the dimension. Enter a known
coordinates and press Enter or click a point in the map.

If the mode for saving was “Save as dimension” and the sub-option for storing
measurements was “Angular dimension” then the user will be prompted for a
point where to position the vertex of the angular dimension. Enter a known
coordinates and press Enter or click a point in the map. Next the user will be
prompted for a point for the first reference point. Enter a known coordinates and
press Enter or click a point in the map. Next the user will be prompted for a point
for the second reference point. Enter a known coordinates and press Enter or
click a point in the map. Finally the user will be prompted for a point where to
position the dimension. Enter a known coordinates and press Enter or click a
point in the map.

If the mode for saving was “Save as attribute” the user will be prompted for a
point where to position the block with an attribute. Enter a known coordinates
and press Enter or click a point in the map.

If the mode for saving was “Save as an extrusion” the user will be prompted to
select one or several region objects. Select the objects you want to extrude and
press Enter. To see the result of the extrusion, you should change the view of the
map to a 3D viewport.

Example: how to extrude features to 3D

In this example, the saving measurements capabilities will be used to extrude 2D
features (buildings), to convert them to 3D features using the Height
measurement tool. Follow the steps below:

Open AutoCAD 2007/2008/2009 and a dwg file with 2D features.

Features to be extruded must be regions, so if it not the case, select the Draw >
Region command, or the Region tool from the Draw toolbar in AutoCAD. Then
select the features to be converted to regions and press Enter. When doing this
be aware that the new feature is added to the active layer.

On the left the building footprints (orange) before converted, drawn as Polylines,
and on the right, after using Region tool (white).
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3. Tilt the view using the View > 3D Orbit menu to better appreciate the 3D

conversion.

4. Open the BlomURBEX viewer if it was closed. Click in “Center in new map point”
button and select a point in the map in the middle of the zone of interest. Switch
to a oblique view. If view does not switch to any oblique view, check the
“intelligent behaviour” and zoom in to closer zoom level, and then retry changing
to any oblique view modes (North, South...). When the city buildings are best
viewed then, proceed to next step.

General] Layout] Linking] Prirting ~ Saving l Dverlays]

Options for saving measurements:
Table: |<Sa\-'e az extrugion [only for heights)z j
Calumn for areas: | <MNone: ﬂ E
Calumn for distances: |<N0ne> j
Colurnn for heights: |<Save ag extrugion [only for heights)s j B
B
Caolurnn faor elewvations: | <Mone j 4
Colurnn Faor % coords: | <Maone: j
Calumnn faor Y coords: | <Noner j
Column for bearings: | <Manes j
I
Open... | Save... | QK. | Cancel | ’
TR ST —— FTTIVW /T S

5. Change “Saving” settings in the Settings dialog as previously indicated. In the
Settings dialog set the table name to “"<Save as extrusion (only for heights)>",
and in the column for heights dropdown box select “<Save as extrusion (only for

heights)>".
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6. Check the File > Start saving measurements in BlomURBEX viewer toolbar to
initialize saving session.

7. Select the Height tool. Measure heights in the buildings. Each height measured a
message box appears with information about the measure to be saved. Click
“Yes” to proceed. Then select the feature or features to extrude. Finally press
Enter. The selected features are extruded.
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12 Overlaying tile raster data

BlomURBEX Viewer is able to overlay tile raster data from BlomURBEX server,
both in "Ortho” and “Oblique” modes. In next chapter is explained how is possible
to overlap also local vector data loaded in AutoCAD 2007/2008/2009. Both tile
raster layers and local vector layers can be overlapped at the same time over the
BlomURBEX Viewer. They all are treated as layers and drawn on top of the
basemap imagery.

12.1 Activating and deactivating raster overlays

To activate or deactivate the raster overlays follow these steps:

1. Click in the Settings > Open Settings dialog menu.

2. Select the Overlays tab.

3. Each time the settings dialog in opened, a query is done to the
BlomURBEX server to return the available tile layers for the current user.
Remember when changing the UserToken option to close the dialog clicking OK
button and to open again the dialog, because each UserToken has permission for
different tile layers depending on user restrictions. Indeed, it is possible for a
customer to host his vector data at BlomURBEX through a rasterization process.

Generall La_l.Jc'utI Linkingl F'rintingl Saving Owerlaps |

™ Oweilay vector layers over BlomlJRBEY imagery

Paoints of inkerpalation: | 100

Tile layer to owerlay from server:

generic
teleatlas
lod35
solar
hillzhade
ubiestO

Open... Save.. | QK | Cancel |

4. Select one or several layers from the list "Tile layer to overlay from
server”. Click once to select and once again to deselect.

5. Click OK to save the setting and start overlaying or clean overlays. This
setting is not saved in user registry for better performance initialization.
BlomURBEX Viewer always start with the setting unselected. It is needed to set it
explicitly in each BlomURBEX Viewer session.
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13 Overlaying vector data

BlomURBEX Viewer is able to overlay vector data from AutoCAD 2007/2008/2009
on top of BlomURBEX imagery, both in "Ortho” and “"Oblique” modes.

13.1 Activating and deactivating vector overlays

To activate or deactivate the vector overlays there are two options with the same

result:
1. Click in “"Overlay vector layers over BlomURBEX imagery” button in the

BlomURBEX toolbar &%,

OR
2. Click in the Settings > Open Settings dialog menu.
3. Select the Overlays tab.

Generall La_l.Jc'utI Linkingl F'rintingl Saving Owerlaps |

[ Oweilay vector layers over BlomlJRBEY imagery

Paints of interpalation: | 100

Tile layer to owerlay from server:

generc
teleatlas
lod35
solar
hillzhade
ubiestO

Cahcel |

4. Check or uncheck the “Overlay vector layers over BlomURBEX imagery” checkbox
to activate or deactivate overlays, respectively.

5. Click OK to save the setting and start overlaying or clean overlays. This setting is
not saved in user registry for better performance initialization. BlomURBEX
Viewer always start with the setting uncheck. It is needed to set it explicitly in
each BlomURBEX Viewer session.

when overlaying a big number of features over oblique images. Read below for

@ Overlying on top of oblique imagery may be a long time operation. Be patient
tricks to improve performance.
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13.2 Refreshing vector overlays

When Overlay option is activated all the existing layers in the AutoCAD
2007/2008/2009 map display are added to BlomURBEX views. If a new layer is
added or any feature is modified in its geometry after activating the Overlay
option, these changes are not shown immediately. To reflect these changes is
needed to click in the “Reload overlays” button in the BlomURBEX Viewer toolbar
¥ . This function adds again the layers to BlomURBEX, clean all the overlays and
redraw again the vector data.

@ﬁutoEAD 2007 - UNREGISTERED YERSION
File Edit “iew Insert Format Tools Draw Dimension Modify  Window Help

e JEel Ok el ¢|<po » & PEIEIET

= tl: ocuments and Settingsmanidesktop’,

el Sl — !

El
Filevﬁ & @ |xr Ll D Br & H] 'E | settings ~ 7+

Before refreshing Vector layer
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E.! AutoCAD 2007 - UNREGISTERED YERSION
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After refreshing Vector layer

When overlaying vector data in oblique imagery, remember that vertexes of the

geometries should match with the imagery at the ground level, not at the roof level.
That is the reason of the apparent offset seen when overlapping over oblique
imagery.

13.3 Overlay and performance considerations

To overlap geometries faster, a combination of requests to BlomURBEX server
and local interpolations is done. It is possible to adjust the precision of the
interpolations.
For that, follow these steps.

1. Open Settings dialog.

2. Select the Overlays tab.

3. The amount of points used for the interpolation determines the accuracy.
It is possible to use no less than four points and no more than 400 points.

Change this clicking up or down the “Points of interpolation” textbox. More points
interpolate more accurately but is slower. Default is 100.
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Puointz of interpolation: 100

Ak

When Overlay option is activated, only visible features inside the visible extent
are sent from AutoCAD 2007/2008/2009 to BlomURBEX Viewer and rendered on
top of BlomURBEX imagery. Try to limit the amount of features to be sent or the
BlomURBEX Viewer performance will decrease when overlapping imagery. To limit
the number of features follow this advices:

1. Remove those layers that do not contain entities, or that contain blocks or
references. Blocks and references are ignored when overlapping. If the drawing
contains a big number of temporary layers, blocks, and references, consider the
creation of a new version of the drawing using only the entities that can be
overlapped.

2. Use DWG format better than DXF format.

3. Use Color ByLayer and Line Type ByLayer. This has a great impact in
performance. BlomURBEX viewer is optimized to show GIS-like vector data that
uses one style per layer, instead of CAD-like vector layer, where each entity can
be drawn with different style properties.

4. Hide in AutoCAD 2007/2008/2009 those layers that are not relevant.

5. Zoom in inside “Ortho” BlomURBEX views so the visible extent contains a
small number of features. Only features that fall inside the visible extent are
overlaid. The zoom level is not a consideration in “Oblique” mode.

13.4 Symbology limitations

The BlomURBEX Viewer has less symbology properties than AutoCAD
2007/2008/2009. These are the limitations of the current version:

1. Only AutoCAD 2007/2008/2009 entities that support the LightWeightPolyline
interface are sent to BlomURBEX. For example, ellipse or circle elements are not
drawn in BlomURBEX. Arcs entities are treated as straight lines and the curved
lines are not preserved. Each element in the drawing is draw with its own color
and width, or the Layer one if the element has the BylLayer color and width.

2. Points are visible.

3. Polylines supported are always shown as solid lines, but the width and color are
correctly chosen.

4. Polygons and the rest of AutoCAD 2007/2008/2009 entity types are not
supported.
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14 Uninstalling BlomURBEX Plug-in for AutoCAD

2007/2008/2009

To uninstall follow these steps:

1. In the Windows Control Panel, open the “"Add/Remove programs”, select
BlomURBEX Plug-in for AutoCAD 2007/2008/2009 and uninstall, following the

guidelines.
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15 Troubleshooting

15.1 Log files

If the applications do not work as expected, the best way to know what is
happening is to activate the logging utility.

In BlomURBEX Viewer, to activate logs, open the Settings dialog, and in the
General tab, select the desired level for logs. A log file or several, one per
process, will be created in the [User Application Data] \ BlomURBEX2D folder
(usually c:\ Documents and Settings \<username>\Application
Data\BlomURBEX2D). To deactivate logs just select None as log level. To activate
logs select Error, Warning, or Information level (in order from minimum to
maximum verbose).

General |La_l,.l0ut| Linkingl F'rintingl Savingl Elverla_l,lsl

Data zource IBIomUHBEX 'I

ser Token:

Bazelayer priority

Ipictometr_l,l,countlyortho,satellite

Units Select interface language: Log level:
= Meters IEninsh j INc-ne j
" Feet
Delete cache |
Open... Save... | Ok Cancel

Log files offer the time and some information about events that occur in the
applications that can help to solve some problems. Otherwise, if the problem is
not known, send the log files with your comments to Blom Technical Support to
help in fixing the problem. You can use the menu? > Send feedback to send an
email.

7~
‘.Q Blom Pictometry website...
|| send feedback...

2= Open About dialeg...
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15.2 Cache directory

The BlomURBEX Viewer creates a cache folder stored in “[User Application Data] \
BlomURBEX2D \ cache” folder (usually c:\ Documents and Settings
\<username>\Application Data\BlomURBEX2D\cache). This cache folder store
tiles for faster retrieve of them.

To avoid this folder to resize to a big amount of bytes, it is possible to delete its
contents periodically. Deleting the cache folder also ensures that the last tiles are
downloaded.

To delete the cache click in the Delete cache button from the General tab of the
Settings dialog, or just delete its content from Windows Explorer.
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16 Frequently Asked Questions

1. Why I do not see the visible and total extent of images in AutoCAD
2007/2008/2009?
Ensure checkboxes in “Linking” tab of BlomURBEX Viewer Settings dialog are

checked.

2. Why the point I select in AutoCAD 2007/2008/2009 is not exactly the
same in the image in BlomURBEX Viewer?

The data opened in AutoCAD 2007/2008/2009 can be in any coordinate system.
When digitizing this data, a coordinate system was used, defined by some
parameters that describe the Earth and how to convert between projections.
BlomURBEX Viewer uses the DotSpatial library to perform transformations
between any projection and Mercator Spheric (EPSG: 3785), the default
projection that use BlomURBEX Web Services at the moment. If the parameters
used by the operator that digitizes the data opened in AutoCAD 2007/2008/2009
and the parameters used in DotSpatial are not the exactly the same, some shift
can occur in the location. In order to minimize this shift, it is possible to modify
the epsg file that comes in the BlomURBEX install dir. The parameters must
comply with the rules that expect DotSpatial (PROJ4 format). To know more
about this, check the appendix below.

3. Why the measurements are not saved in AutoCAD?

The requirements to save measurements in AutoCAD are the following. If any of

this requirements are not fulfilled the saving will not takes place.

e In the BlomURBEX Viewer settings dialog a table and a field must be selected
for the desired measurement type. To store heights, the correct dropdown box
with the field for heights must be selected, for example. If the dropdown has
<None> selected that measurement will be ignored.

e The “File > Start saving measurements” menu must be checked.
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The projection support relies on the DotSpatial public domain library. In the
installation folder of BlomURBEX Viewer a file “epsg” is provided that contains
EPSG codes, names and parameters for the EPSG coded projections. If you need
to modify an existing projection, or to add support for new projections, modify
this file with any text editor following the DotSpatial (Proj4) rules for parameters.
See the http://proj.maptools.org/ webpage for more information.

For example, if support for the Microsoft Live Maps projection is needed, add the
next two lines to the file (the second line looks longer but is only one):

# World Mercator

<54004> +proj=merc +lat_ts=0 +lon_0=0 +k=1.000000 +x_0=0 +y_0=0
+ellps=WGS84 +datum=WGS84 +units=m no_defs <>

Or support for Google Maps projection:
#Google

<900913> +proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0
+x_0=0.0 +y_0=0 +k=1.0 +units=m +nadgrids=@null +wktext +no_defs <>

For optimize the Select projection dialog, delete from the “epsg” file any
projection not needed. Remember that each projection in the file uses two lines,
so do not break the format of this file or BlomURBEX Viewer could not work
correctly.

Once the “epsg” file is modified, open again the Settings dialog in BlomURBEX
Viewer and reselect again the projection to refresh internal BlomURBEX settings.
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BlomURBEX Viewer interface supports twelve languages. The strings for each
language are stored in the registry, in the path HKEY_LOCAL_MACHINE /
SOFTWARE / Blom / Urbex 2.0. Each language has a section: english (en),
espanol (es), deutsch (de), francais (fr), italiano (it), nederlands (nl), portugués
(pt), dansk (da), norsk (no), svenska (sv), suomi (fi), romana (ro).

Each string uses a pair name-value. The name is an easy-to-understand name.
For example, "AboutBoxForm.Description” is the description for BlomURBEX
Viewer that appears in the "About” dialog. Change these values at your
convenience using the registry editor. Next time you open BlomURBEX Viewer will
reflect your changes. If any value is missing, the default value used is the English
string.

If you found wrong strings in your language and want to help us improve the
software, feel free to send us an export of the registry language settings to the
Blom Technical Support email using? > Send feedback menu in BlomURBEX
Viewer.

¢ Editor del Registro
Archivo  Edicion Wer  Favoritos  Ayuda

EELS [ Nombre Tipo [ Datos
D HEEY_CLASSES_ROOT @ )] REG_SZ (valor no establecido)
{1 HKEV_CURRENT_USER [ab]aboutBoxForm. Description REG_52 Urbex er en Blom webtjeneste, der udgiver ortho og skr8 billeder. {0} er udviklet
(] HKEV_LOCAL_MACHIKE E OKButton REG 57 ok
{0 HARDWARE [a Title REG_5Z om {0t
8 SAM a nText REG_SZ Aben AboLt Didlog ...
a :Z?}ls;;;g a ooltip REG_52 Samarbejdsomr&ds varkis;
TTooltip REG_SZ Under middel
72 =
B g Adt‘lipja =t metry\WebsiteButton Text REG_SZ Blom Pictometry website ...
at onTooltip REG_SZ Ry kart
=+ Blom = =
D Blom Pictametry Controls 1.5 ; |CoordinateForm.btnCancel REG_5Z Annuller
D Blom Pictometry Viewer 1.5 ; [CoordinateForm, btnok. REG_5Z oK
£ Urbex2.0 [3b]coordinateForm. btrSelectProj REG_5Z veslg ...
Ha [B]coordinateForm. Caption REG_SE G5t at koordinere
- de [B]coordinateForm. label1 REG_SE % eller Leengdeqrad:
Den [3B]CoordinateForm labelz REG_52 ¥ eller Breddeqrad:
@es [3B]CoordinateForm1 REG_SZ Numerisk vzerdi krasvet
~@ A [3B]DistanceButtorTaaltip REG_SZ Distance vasrkts)
Qfr [B]EastauttanTaakip REG_SZ Vis Fra gt t vest
~@ it [3B]ElevationsuttonToolip REG_SZ Hajde vaerktai
Qnl [EB]ExtracteuttonTackip REG_SZ vesrktgjet Extract
8 m [ len REG_5Z File
- b= f; C Hajde vasrkraj
;
s =
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